fuchsia在ubuntu18.04环境编译问题

%E6%97%A0%E6%A0%87%E9%A2%98
翻墙从Google下载的最新全代码怎么编译报上面的错误,有人遇到过吗?

jun@ubuntu:~/fuchsia$ fx set
ERROR: Missing an explicit PRODUCT.BOARD goal.
ERROR: You must specify which product and which board you wish to build.
ERROR: Example:
ERROR:   fx set core.x64
ERROR: 
ERROR: Run "fx list-products" to see the available products.
ERROR: Run "fx list-boards" to see the available boards.
ERROR: Run "fx set --help" to see full usage.
jun@ubuntu:~/fuchsia$ fx set core.x64
ERROR at //build/config/fuchsia/zircon.gni:76:3: Script returned non-zero exit code.
  exec_script(
  ^----------
Current dir: /home/jun/fuchsia/out/default/
Command: /usr/bin/env /home/jun/fuchsia/buildtools/gn gen -q --root=../../zircon --args=# THIS FILE IS CLOBBERED.  DO NOT EDIT!
# Instead, edit //out/default/args.gn to add
# zircon_args = { ... } to replace the defaults above.
forward_variables_from({
  default_deps = [":legacy-x64"]
  enable_kernel_debugging_features = false
  enable_netsvc_debugging_features = false
  goma_dir = "/home/jun/goma"
  use_goma = false
  variants = []
}, "*") --export-compile-commands=default ../default.zircon
Returned 1 and printed out:

ERROR at //public/gn/toolchain/clang.gni:30:17: Could not read file.
      read_file("$_prebuilt_dir/.versions/clang.cipd_version", "json")
                ^--------------------------------------------
I resolved this to "/home/jun/fuchsia/zircon/prebuilt/downloads/clang/.versions/clang.cipd_version".
See //public/gn/toolchain/c_toolchain.gni:6:1: whence it was imported.
import("clang.gni")
^-----------------
See //public/gn/toolchain/environment.gni:6:1: whence it was imported.
import("c_toolchain.gni")
^-----------------------
See //public/gn/fuzzer/BUILD.gn:5:1: whence it was imported.
import("$zx/public/gn/toolchain/environment.gni")
^-----------------------------------------------
See //BUILD.gn:221:5: which caused the file to be included.
    "$zx/public/gn/fuzzer:noop-test.fuzzer",
    ^--------------------------------------

See //BUILD.gn:5:1: whence it was imported.
import("//build/config/fuchsia/zircon.gni")
^-----------------------------------------
jun@ubuntu:~/fuchsia$
jun@ubuntu:~/fuchsia$ ls
AUTHORS  build     buildtools  CODE_OF_CONDUCT.md  docs      garnet  integration  out     PATENTS  prebuilt  README.md     scripts  src          tools  zircon
boards   BUILD.gn  bundles     CONTRIBUTING.md     examples  infra   LICENSE      OWNERS  peridot  products  rustfmt.toml  sdk      third_party  topaz
jun@ubuntu:~/fuchsia$ du -h -d1
36K	./products
6.0M	./peridot
20K	./out
44M	./docs
27M	./.jiri_root
384K	./examples
3.2G	./garnet
1.9G	./buildtools
95M	./zircon
6.2M	./integration
67M	./src
212K	./infra
280M	./.cipd
1.1G	./prebuilt
8.3G	./third_party
2.6M	./tools
80M	./build
4.0K	./.ssh
1.8M	./scripts
311M	./.git
473M	./topaz
5.1M	./sdk
56K	./boards
24K	./bundles
16G	.

你仔细看错误提示,我想已经提示的非常清楚了:

ERROR: Missing an explicit PRODUCT.BOARD goal.
ERROR: You must specify which product and which board you wish to build.
ERROR: Example:
ERROR:   fx set core.x64
ERROR: 
ERROR: Run "fx list-products" to see the available products.
ERROR: Run "fx list-boards" to see the available boards.
ERROR: Run "fx set --help" to see full usage.

我后面执行example了还是报错,是什么依赖库未安装吗?
jun@ubuntu:~/fuchsia$ fx set core.x64
ERROR at //build/config/fuchsia/zircon.gni:76:3: Script returned non-zero exit code.
exec_script(
^----------
Current dir: /home/jun/fuchsia/out/default/
Command: /usr/bin/env /home/jun/fuchsia/buildtools/gn gen -q --root=…/…/zircon --args=# THIS FILE IS CLOBBERED. DO NOT EDIT!

Instead, edit //out/default/args.gn to add

zircon_args = { … } to replace the defaults above.

forward_variables_from({
default_deps = [":legacy-x64"]
enable_kernel_debugging_features = false
enable_netsvc_debugging_features = false
goma_dir = “/home/jun/goma”
use_goma = false
variants = []
}, “*”) --export-compile-commands=default …/default.zircon
Returned 1 and printed out:

ERROR at //public/gn/toolchain/clang.gni:30:17: Could not read file.
read_file("$_prebuilt_dir/.versions/clang.cipd_version", “json”)
^--------------------------------------------
I resolved this to “/home/jun/fuchsia/zircon/prebuilt/downloads/clang/.versions/clang.cipd_version”.
See //public/gn/toolchain/c_toolchain.gni:6:1: whence it was imported.
import(“clang.gni”)
^-----------------
See //public/gn/toolchain/environment.gni:6:1: whence it was imported.
import(“c_toolchain.gni”)
^-----------------------
See //public/gn/fuzzer/BUILD.gn:5:1: whence it was imported.
import("$zx/public/gn/toolchain/environment.gni")
^-----------------------------------------------
See //BUILD.gn:221:5: which caused the file to be included.
“$zx/public/gn/fuzzer:noop-test.fuzzer”,
^--------------------------------------

See //BUILD.gn:5:1: whence it was imported.
import("//build/config/fuchsia/zircon.gni")
^-----------------------------------------
jun@ubuntu:~/fuchsia$

遇到相同的问题。然后装了debian系统,大概build成功了